become.1 GmbH - AWS Account Blocked Due to High Email Bounce Rate – Incident details

AWS Account Blocked Due to High Email Bounce Rate

Resolved
Operational
Started 4 months agoLasted 1 day

Affected

App

Operational from 10:00 PM to 2:21 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. We will closely monitor the service to prevent this from happening again.

  • Monitoring
    Monitoring
    We are currently experiencing an incident that has led to our AWS account being blocked, impacting our email sending capabilities. **What Happened:** An internal notification email address, previously configured in multiple locations within our system, was recently deleted. Despite its deletion, our systems continued to send a high volume of emails to this address. As a result, all emails sent to this non-existent address hard bounced. **Impact:** The continuous sending to the deleted email address caused our overall email bounce rate to surge, reaching approximately 22%. When the bounce rate exceeded 20%, Amazon Web Services (AWS) automatically blocked our account, preventing us from sending any further emails. **Current Status:** We've **identified the root cause** of the issue and have **rectified the problem** by removing the deleted email address from all configurations. We are now **awaiting AWS to unblock our account** so we can resume normal email operations.